We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2007
    Posts
    1,534

    Lotro Client Patching Issue

    I just tried to start up the game, now that the servers are back online. The Lotro client downloaded the update files, but then it tried to go through the validation of the files, failed, and put up the same error message that the guy posted to your General Discussion forum. Now the client tries to redownload the files, but cannot, and cannot update.


    UPDATE for the benefit of those dealing with this issue:

    The patcher is failing to completely patch the client. This is the error it gives:

    Cannot patch file "lotroclient.exe" error 5: access is denied.

    When you close the error message, it is immediately followed up with a second message that says:

    Failed to restart the launcher, error 2: the system cannot find the file specified.

    I use Avast for malware protection. I made exceptions for the lotroclient.exe, the turbinelauncher.exe, and another file that I can't even remember at the moment, and then I ended up exempting the entire game installation folder.

    None of that helped. After rebooting the computer, attempting to patch the game failed again. And, as it turned out, the culprit was Avast. It just simply refused to allow any program or installer to access the main LOTRO game files. It also argued with me about uninstalling Avast, so I ended up going into the system services and manually shutting down several running services of Avast. That enabled me to uninstall Avast, which will never see the inside of my computer again!

    After Avast was uninstalled, Windows Defender Firewall kicked in and did the same thing, and would not let me or anyone else have access to the game files. But Windows Defender DID allow the exemptions, and after I exempted the launcher and the "lotroclient_awesomium.exe " file, the patcher was finally able to completely patch the game and I was finally able to get into the game again.

    The lesson? Apparently Avast doesn't pay a whole lot of attention to exemptions and doesn't want you to be in control of your own computer. Solve that problem first, and then the other problems will be easy to fix.

    And no thanks at all to SSG for ignoring my ticket and spending the day scratching their heads. I was on my own with this one! Not fun!
    Last edited by Hammerfast; Dec 18 2019 at 04:09 PM.

  2. #2
    Thank you very much for your post!

    I also found another way around it in case it helps anyone. Apparently, the "lotrolauncher64.exe" somehow moved to the "tmp" folder, so I just copied it and pasted it unto the "x64" folder and it worked like magic!
    [charsig=http://lotrosigs.level3.turbine.com/0e21500000006449c/01006/signature.png]undefined[/charsig]

  3. #3
    I had a similar problem, but in my situation, the Avast was in process of update too and then they blocked the lotro program.
    After a restart of the computer, the Avast update was completed, and then the game was allowed normally again.

  4. #4
    I may be having a similar issue, so thanks. Just re-downloading the entire thing now.

    I'll add the exceptions to Defender and see if that helps. The crash happens so fast I can't see the error... are there any logs I can look at ? Event Viewer just tells me a "generic Error" occurred.

    Last time I played Turbine were still the devs, so I thought I'd give it a try again.

  5. #5
    Ok, Steam versions launched just fine.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload